Follow

What Are the Minimum Requirements to Run TouchCast on an iPad?

TouchCast requires an iPad 2 or faster.  Certain features such as video import and the video vApp require the iPad 4, iPad air or iPad mini current generation.  Overall, TouchCast functions best on newer, faster devices.  

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments